Dbs Connection Issue.... 关注

-1
Avatar
Legacy Poster

Hello,
 
I'm very new with BT and have to come with some solution for label printing in
very limited time. I would be grateful if somebody can support me and give me directions for solving
my issues which I believe are quite basic for average user.
 
We use BT ver. 9.01
 
I created in BT Test Report label format which should be printed using data from several MS Access db's.
The data are choosen according the unique SerNo that has to be entered during print time.
 
The problems:
 
1. SIMILAR DB FIELDS WITH EMPTY CHARACTERS IN FRONT 
The same field (6 dIgits) that has to be used for for Multi-Databse Joins in one database has allways one or two
empty characters in front before begins, and in the other db not. Due to this I assume that the Join cannot recognize right field
in the 2nd db and in the print time I have message "No record found"? The db's are automatically updated and I cannot
do nothing to correct the field in the db. I have to make solution in BT.
 
And 2nd is one general recommendation regarding the printing....
 
2. SIMPLFY PRINTING WITH DEDICATED USER FORM
Is it possible to simplfy printing process and not open BT and print directly from it (File ->Print....) in a way that kind of a custom Printing Interface is created that consist only for this case important fields (Query Field, Printer choice, Print preview and choice of several differnet
Label layouts)? 
 
Thanks in advance for help!
 
br
alen

1 评论

0
Avatar
Peter Thane
评论操作 固定链接

Been a while since I "played" with 9.01 but for

1. Have you tried the More Options (I think it was called) for the Query and the Truncation option to discard the leading 2 character for the field in question.

2. I cannot remember at which version it was added and so may not be available for you, but the Print Station application sounds like what you are looking for and so it maybe worth downloading the latest Trial version and having a play with this to see that meets your requirements. 

请先登录再写评论。