Database Connection Field is NOT empty, but Bartender is stating Empty 关注

0

Hi Guys,

Have a database connected to Bartender....there are total of 8 fields....Total Database is about 1500 records.  In one of the fields, the data changes from Numerical to Text at record number 900.  When I try to test print, print preview, or go into that field and look at database connection setup, the field is empty.  Obviously Bartender thinks this field is empty, when in actuallity it has text data.

 

Please note the field in question has been double checked to ensure all allowable characters are included under validation.

If anyone has any suggestions, that would be great

 

thanks

5 评论

0
Avatar
Peter Thane
评论操作 固定链接

I think this is an ODBC driver issue. No matter what format you set the field to (ie making it a Text field) the ODBC will look at the first few records and if it sees just numbers then it will make this a numeric field and so when the data is passed to BarTender the later text strings will no longer appear.

A simple work around to this is add a new record at the top and give every field the value dummy and so the ODBC driver will then know the field is text. 

0
Avatar
Mehmet Başıbüyük
评论操作 固定链接

The same issue happened on our Excel connection. All the fields have datas but inside the Bartender preview some record fields seem empty. 

Bartender accept the whole column as text or number e.t.c according to database logic but the field type changes field by field. Some rows includes only numbers and some are alfanumeric.

We formatted the respective columns as texts then reestablished the database connection. Only then we could successfully preview and print all the datas we need.

Hope that helps who faces the same problem.

0
Avatar
Jeff Keller
评论操作 固定链接

When running the Database Wizard, uncheck:  "Use automatic field type detection"

0
Avatar
Peter Thane
评论操作 固定链接

The only time I have seen this (as per the comment from a few years ago) is if the data in the fields starts as numeric only and then becomes either alpha only or alphanumeric. The formatting of the cells/columns in the Excel sheet doesn't make any difference as it looks like the ODBC driver just interrogates the cells in the first couple of records to decide the type or data, which in the above would mean it then sets them to numeric only and so any later data that doesn't match this is blank.

Adding a "dummy" record at the top of the spreadsheet with text in those cells gets round this. 

0
Avatar
Jeff Keller
评论操作 固定链接

Pete,

As a matter of fact, this column did just that. Started with numbers and went to numeric. I had a feeling it was due to the mixed content so found the option to disable auto detect and figured I'd post it just in case someone stumbled across it.

Something about leaving an easily answered thread, unanswered.

请先登录再写评论。