跳至主內容

搜尋

搜尋

Configurable Default Value - True Type Font Warning?

評論

18 條評論

  • Avatar
    Ian Cummings
    版主
    Disable this via the Print dialog under the Performance tab. Deselect the "Warn when using true type fonts" option. However, this only applies to future use of label formats. For any label formats affected by previous, erroneous substitutions you will need to open the label format, select all or specific text object, open the properties dialog of the objects and then under the "Font" tab untick the "Substitute with best matching printer font" checkbox. Save the label when done to keep the changes for that label.
    0
  • Avatar
    Legacy Poster
    Thanks for reply Ian. I expected that but I wanted to be sure. /Björn
    0
  • Avatar
    Legacy Poster
    Good Morning, We just recently upgraded several pc's from older versions of the BarTender software to the new V10 software and seem to be getting some issues with the True Type Fonts. They keep getting a warning message dialogue box that pops up. Is there anyway that we can just tell the label to convert to the new format so we don't keep getting this warning message? It seems that there are several labels that keep receiving this even when we tell it to ignore the error message.
    0
  • Avatar
    Ian Cummings
    版主
    Open the "Print" dialog of BarTender, select the "Performance" tab and untick the "Warn when using true type fonts" checkbox.
    0
  • Avatar
    Legacy Poster

    Is there a way to prevent/disable/forbid font substitution for entire system/installation. Our customer see this as a major safety issue and would like to prevent it. They have no performance problems but are cautions about WYSIWYG.

     

    Regards Erik

    0
  • Avatar
    Ian Cummings
    版主

    I suppose you could lock down the permissions on the registry key:

     

    HKEY_CURRENT_USER\Software\Seagull Scientific\BarTender\Preferences

     

    Also you can use the Security Center to lock down the various aspects of the software on a Windows user/group basis.  I advise that you explore that:

     

    http://www.bartenderbarcodesoftware.com/label-software/whitepapers/Barcode-and-Label-System-Security(English).pdf

    0
  • Avatar
    Legacy Poster

    Good idea. How does key:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Seagull Scientific\BarTender\Fonts\Use Baseline WYSIWYG = DBCS

     

    and

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Seagull Scientific\BarTender\Fonts\Use Windows Font Mapper = Yes

     

    affect the system?

     

    Is that a possible way?

     

     

    /Erik

    0
  • Avatar
    Ian Cummings
    版主

    I would suggest that the use of Security Center is your best bet.

     

    The registry keys you specify don't relate to your issue.

    0
  • Avatar
    Legacy Poster

    I have the same problem as the OP.  However, this does not work. 

    Disable this via the Print dialog under the Performance tab. Deselect the "Warn when using true type fonts" option. However, this only applies to future use of label formats. For any label formats affected by previous, erroneous substitutions you will need to open the label format, select all or specific text object, open the properties dialog of the objects and then under the "Font" tab untick the "Substitute with best matching printer font" checkbox. Save the label when done to keep the changes for that label.

    I have selected every bit of text in the label and deselected the "Substitute with best matching printer font" checkbox. In addition, in BarTender, I have printed the label and deselected the "Warn when using true type fonts" option.  Finally, I have saved the label.  From Print Station, I still get the True Type Fonts warning. 

     

    Performance is not an issue here.  I have many operators and hundreds of labels that generate this warning.  I cannot rely on everyone to check the "Disable warning and print True Type fonts." How, exactly, can I completely eliminate the Print Wizard True Type Font warning and set everything to Enable True Type fonts without modifying hundreds of labels?

    0
  • Avatar
    Ian Cummings
    版主

    IcyMountain: Under the "Performance" tab choose the "Use settings for this document only", and then untick the "Warn when using true type fonts" checkbox.  Save the label and restart Print Station if needed.  This embeds the setting with the document in question itself.  The "Use this setting for all documents" setting is limited to that particular user on the specific PC.

    0
  • Avatar
    Legacy Poster

    I'm seeing font substitution with an OpenType font on one of my servers. The option to check is grayed out, how to I disable substitution in this case?

    0
  • Avatar
    Ian Cummings
    版主

    dgabardy: The option is greyed out if the currently selected printer, with which the document is currently opened with, doesn't support any device fonts.  I assume that the printer the document is opened with, as you view it in BarTender, is not the printer that is generally used at print time?

    0
  • Avatar
    Legacy Poster

    It is the same printer. When I print from within BarTender the font is correct. When I send a trigger BarTender substitutes the font. My 2nd server will not substitute when printing to the same printers. Could it be that someone selected to substitute at one point when prompted and now BarTender defaults to that? If so how can I reverse it?

    0
  • Avatar
    Legacy Poster

    Deleted the fonts, reboot, added the fonts, reboot finally fixed the problem!

    0
  • Avatar
    Legacy Poster

    It is the same printer. When I print from within BarTender the font is correct. When I send a trigger BarTender substitutes the font. My 2nd server will not substitute when printing to the same printers. Could it be that someone selected to substitute at one point when prompted and now BarTender defaults to that? If so how can I reverse it?

     

    I have a similar problem, 10.1 SR3

    0
  • Avatar
    Legacy Poster

    After a process of elimination it appears that my problem is to do with "Global Data Fields" remove that field an the problem goes away?

     

     

     

    [attachment=1054:BarTender Automation - Font Test.btw_2014-07-24_10-17-21.jpg]

     

     

     

    [attachment=1055:Configurable Default Value - True Type Font Warning_ - General Discussion - Seag_2014-07-24_10-37-52.jpg]

     

    This is the original problem, when printing from "Print Station"

     

    If I remove the "global field" the warning box does not come up

     

    Printing from "bartender" is no problem, just with "Print Station"

     

     

    BarTender
    The world's leading software for label, barcode, RFID and card printing.
    Edition: Automation (3 Printers)
    Version: 10.1 SR3
    Build: 2954
    Activation Status: Activated
    Support Number: 2V-******-GT3QL-*****
    For sale and use only in the Asia-Pacific region (except Japan).
     

     

    0
  • Avatar
    Domingo Rodriguez
    版主

    In BarTender, open the document in question. Under the "Performance" tab choose the "Use settings for this document only" and then untick the "Warn when using true type fonts" checkbox. Save the label. This embeds the setting with the document in question itself. Restart Print Station. As it has been mentioned previously, the "Use this setting for all documents" setting is limited to that particular user on the specific PC.

     

    Will the problem go away after applying the changes to the document itself?

    0
  • Avatar
    Legacy Poster

    Yes, that has appeared to fix the problem

     

    Leaving a picture for the next person

     

    [attachment=1064:BarTender Automation - Calf Muesli 25kg.btw __2014-07-28_08-00-11.jpg]

    0

登入寫評論。