Webprintserver And Vs2010 追蹤

Legacy Poster

I have deployed a Bartender 9.4 web app on the web print server and the app is working fine. All files in the application live on the web server.

When running the app from my development machine (not the web server), within Visual Studio 2010 using a localhost iis on the dev machine, I get an error when assigning the bartender label file to the LabelFormatDocument. The error is

"This operation cannot be performed unless the engine is running."

Here is the beginning of my vb try statement
--------------begin code------------------
Dim btEngine As New Engine(True)

Using btEngine
Dim filenameandpath As String = ConfigurationManager.AppSettings("LabelRepository") & "Shipping BCode - No Logo.btw"
Dim btFormat As LabelFormatDocument = btEngine.Documents.Open(filenameandpath)
-----------------end code-----------------

I have verified that the bartender label file exists at the location specified. I have tried using both "C:\filename" and a unc to refer to the file and I get the same error for both methods.

Is there something about Visual Studio 2010 and bartender web print server that I am missing? The copy of bartender (9.4SR2) on my development machine is activated and I can print labels from it.

Again, the app is working fine on the web server. I can't debug with Visual Studio and I would like to get this working BEFORE there is something I need to debug. By the way this was working when I was using the trial version. Once we purchased the real product and they reconfigured the license server, then I started getting this error. But the Bartender on my local development machine is finding the correct License Server.

Any suggestions out there?



1 意見

Shotaro Ito
評論操作 永久連結

Hi Terre - do you still have this problem?
The error itself means BarTender process (bartend.exe)failed to start, for some reason.

- After btEngine.Start(), does "bartend.exe" process running?

- Is there any problem running .net SDK samples (such as click print) installed with SDK Documentation?

- Does the account running the application have enough access rights to the BarTnender folders and format folder? (try with local administrators group account.)

- Run command line
[code]"C:\Program Files\Seagull\BarTender Suite\bartend.exe" /register[/code]
once, to register BarTender automation interface again.

- If not tried, please update to BarTender 9.4SR3 - though I cannot say it would solve the problem.
[url="http://www.seagullscientific.com/aspx/fixes_94.aspx"]BarTender 9.4 Service Release[/url]
Hope that helps.