Identical Copies Issue When I Downgrade My Bartender Version 追蹤

0
Avatar
Legacy Poster

Hi,

 

I am new to Bartender and I am writing a label printing for my client. While development i have installed the trial version of Bartender 10.1 and all went well with code below:

 

engine = New Engine(True)
format = engine.Documents.Open(lblFile)

If format.PrintSetup.SupportsIdenticalCopies = True Then
 Dim copies As Integer = 1
 success = Int32.TryParse(txt_count.Text, copies) AndAlso (copies >= 1)
 format.PrintSetup.IdenticalCopiesOfLabel = copies
End If

If format.SubStrings.Count > 0 Then
 Dim bindingSource As New BindingSource()
 bindingSource.DataSource = format.SubStrings
 For Each lItem As SubString In bindingSource.List
  If lItem.Name = "product" Then
   lItem.Value = txt_name.Text
  End If
  ''Checking and setting for all the other SubStrings
 Next
 bindingSource = Nothing
End If

If cmb_printers.SelectedItem IsNot Nothing Then
 format.PrintSetup.PrinterName = cmb_printers.SelectedItem.ToString()
End If

Dim messages As Messages = Nothing
Dim waitForCompletionTimeout As Integer = 10000 '' 10 seconds
Dim result As Result = format.Print(AppConstants.AppName, waitForCompletionTimeout, messages)

And the printing was all went as expected. But when I get to try this on the client machine they had Bartender 9.20 so I reworked the lable files (.btw) and tried running it after few tries i could get the labels printing. Now the issue is irrespective of the copies I set i get only one row printed (ie. 3 labels).

 

My client printer is RING PEL 408+ and the medium used is 104mm which has 3 labels on each row of height 20.6.

 

I also tried Mike's suggestion in the post http://forums.seagullscientific.com/index.php?/topic/1645-the-number-of-printed-label-is-not-correct/ which turned of no use.

 

Thanks in advance.

 

@EDITED

I tried printing from the BarTender application itself specifying the identical copies but the behaviour is same. So hope the code is okay and application configuration has the issue.

 

Any help will be much appriciated.

1 意見

0
Avatar
Legacy Poster
評論操作 永久連結

I have fixed the issue. It was configuration issue.

 

In the Page Setup->Media Handling

Chose Action as Page Break and Occurrence as After Every Page

 

Thanks for everyone.

登入寫評論。