External Picture File 追蹤

0
Avatar
Legacy Poster

I use a spreadsheet for my products. Included on the row for each product is the name of a picture I want to insert on the label for that product. The pictures are stored on my HD.
I use the Cactus Picture drop-down, and select "Get File Name from Database Field". Then in the Properties of the picture I choose the Field Name as the name of the column in the spreadsheet that has the picture name I want. I then use the Default Path to browse to the folder containing the pictures. The pictures are saved as TIFFs, (but I have also tried BMPs). I have made sure the name on the spreadsheet corresponds exactly with the name of the picture file, and I have tried including .tiff after it also, which made no difference.
The pictures do not show on the screen (only the cactus), and when I try to Print or Print Preview I get Error Message #3608 (Image Error -10: The specified file was not found).
Can someone tell me what I am doing wrong please? If you need further info just ask.

14 意見

0
Avatar
Ian Cummings
版主
評論操作 永久連結

Are you including the last back slash "\" in the folder path for the picture object?

Example:

C:\My Pictures\
0
Avatar
Legacy Poster
評論操作 永久連結

[quote name='Ian C - Seagull Support' timestamp='1354709096' post='3843']
Are you including the last back slash "\" in the folder path for the picture object?

Example:

C:\My Pictures\
[/quote]
Thanks for the reply.
Yes I am including that last \, I have tried it both with and without the last \, but to no avail.
I presume the name of the file in the spreadsheet doesn't need to be anything other than plain text? For instance, the first file name is GHS02.tif, in the spreadsheet in the appropriate cell, I have tried both GHS02 and GHS02.tif and neither has worked. All have returned the same error as above.
Just for info, I am currently using the Trial Version (with a view to buying if I can get it to work properly), and the option for Professional.
0
Avatar
Ian Cummings
版主
評論操作 永久連結

Are you able to attach a BarTender document, Excel file and image that demonstrates the issue, so that I may examine what is going wrong?
0
Avatar
Legacy Poster
評論操作 永久連結

I have uploaded the BarTender document, but the site will not allow me to upload any excel document.
I have also uploaded one of the pictures (it's a BMP as the site won't let me upload a TIFF either), and a screen shot of the excel spreadsheet.

This is not the original work, but the problem is the same on this also.
0
Avatar
Ian Cummings
版主
評論操作 永久連結

1. You need to specify the full file name so include the ".bmp" file extension.

2. The image file name contains a space character between "GHS" and "02". Either modify the field data in Excel to be "GHS 02.bmp" or change the name of the file to be without the space.
0
Avatar
Legacy Poster
評論操作 永久連結

[quote name='Ian C - Seagull Support' timestamp='1354720587' post='3847']
1. You need to specify the full file name so include the ".bmp" file extension.

2. The image file name contains a space character between "GHS" and "02". Either modify the field data in Excel to be "GHS 02.bmp" or change the name of the file to be without the space.
[/quote]
Brilliant, thank you. The space was a mistake in the uploaded file, it isn't in the original, sorry about that, but adding the file type worked on the original, (it seems I did something wrong the last time I tried that).
Thanks again.

One more question now, if the field is blank in the spreadsheet (which for some products it has to be), how can I prevent it from returning a print error?
0
Avatar
Legacy Poster
評論操作 永久連結

Any ideas on the above question?
0
Avatar
Ian Cummings
版主
評論操作 永久連結

If you data source a picture object by linking to the path and file name, then specifying nothing for the file name will result in no picture object printing. However, when you do this you need to set the picture sourcing error handling under the "Picture" properties to "Never abort print job" when picture file is not found.
0
Avatar
Legacy Poster
評論操作 永久連結

Ok, will do, thanks again.
0
Avatar
Anoop Jacob
評論操作 永久連結

Team,

I have the similar issue.

In my case - I am using Bartender version BarTender Designer 2016 R2 11.0.2.3056 - Enterprise Automation.

I have an excel with a field name - Picture under which I have a file name call Pic1.jpg (No spaces, No extra characters - all checked)

Now, on bartender, I configured the database and in the label design, I use External Picture File - Get file from Database field.

Changed the field to "Picture" from the drop down. Path mentioned is C:\Users\Grace\Desktop\Pictures\ - NO LUCK

Also tried the path as \\computer name\Users\Grace\Desktop\Pictures\ - NO LUCK

I get the same error #3608 and says the file cannot be found. The path is absolutely correct.

Am I missing something here?

Yes - I did check for the exact file type and entered the exact file name with extension

There is no space in the file name or even the path has been checked a million times

At the same time, barcodes, MRP, Dates and everything works well from the same database. 

Could someone please help? -Its very critical.

0
Avatar
Anoop Jacob
評論操作 永久連結

Oh yes - I even tried to Hyerlink the picture on excel - NO LUCK :(

0
Avatar
Ryan Mattson
評論操作 永久連結

Looking for an answer to this also. I have an Excel database with an image. No spaces, the files exists.

My version 11.2/160168
Error: BarTender Warning Message #3608
An error occurred or the picture file".........." was not found.
Picture Object: "Picture 2"
Image Error -10: The specified file was not found.

In my case the image still prints on the label but the error message is annoying and happens twice with every print.

0
Avatar
Ian Cummings
版主
評論操作 永久連結

Ryan: Are they picture files stored on a local drive of the BarTender computer?  It could be that there is a bit too much latency to get the picture data in time to the BarTender print engine, which ends up tripping the warning somehow.  Note that you can use the error handling settings for the picture object to suppress the error messages if applicable.

0
Avatar
Martijn Meier
評論操作 永久連結

Having the same issue here. Seems printer driver related. When using Cab A6+ (300 dpi) driver I get the warnings and printing fails. No issue when using another brand of a driver (tested with a Domino & Canon drivers).

The files mentioned in the Warning (I get 2 too) do exist, they show up using the Designer. I can print from the Designer too, but not when using an Integration.

Installed BT 2021 R2 this morning, unfortunately it dit not solve the issue.

登入寫評論。