Label Text Incorrectly Positioned 追蹤

0
Avatar
Legacy Poster

I'm trying to print labels labels on a datamax-o'neil H-class 4606 printer using BarTender Enterprise Automation (Trial) version 10.0 SR1 Build 2845. OS is Win 7 Prof x86 SP1.
Driver is Datamax-O'Neil DPL Driver ver 7.3.1. Printer is connected via ethernet.

Labels are on a roll, 3 columns, each label is 30 (width) x 14 (height) mm.

I have to locate the label text 5mm down and 5mm to the right from the upper right corner in the degin window to have the upper right character be printed in the upper right corner of the label. That means that there's room for 2 more lines above my 3 existing lines in the design windows, but 2 lines BELOW the 3 printed lines.

I'm don't understand what I need to change to have the printed position (on the label) match the design relative position (on the label).



Also, setting System setting to use "metric" uom, doesn't seem to impact the media settings (label size); they're still prompting for values in inches. :(

Please Help!

8 意見

0
Avatar
Fernando Ramos Miracle
版主
評論操作 永久連結

This certainly looks like a page setup problem, please try the following:

1. Could you access the "File>Print..." dialog, click on the "Document Properties..." button and, under the "Stock" tab, make sure that the correct media handling settings are specified (continuous roll and gap type specially)?

2. Also, if you open the "File>Page Setup..." dialog, under the "Layout" tab make sure that BarTender calculates automatically the template size (you only need to set the paper size on the "Page" tab, mark how many columns your stock has and the gaps between your labels).

Does this help with your issue?
0
Avatar
Legacy Poster
評論操作 永久連結

[quote name='Fernando R-Seagull Support' timestamp='1345817693' post='3144']
This certainly looks like a page setup problem, please try the following:

1. Could you access the "File>Print..." dialog, click on the "Document Properties..." button and, under the "Stock" tab, make sure that the correct media handling settings are specified (continuous roll and gap type specially)?

2. Also, if you open the "File>Page Setup..." dialog, under the "Layout" tab make sure that BarTender calculates automatically the template size (you only need to set the paper size on the "Page" tab, mark how many columns your stock has and the gaps between your labels).

Does this help with your issue?
[/quote]

This does not help. All printed labels are identical, i.e. template size is correct, it's "just" that it's as if the printed output is offset quite a few millimeters to the right and down relative to the design.

Edit: Got tech support today. I had to use the ROW/COLUMN adjust in Print Control Settings.
0
Avatar
James Mitchell
評論操作 永久連結

I had to use the ROW/COLUMN adjust in Print Control Settings.

Please may you explain (or anyone else for the matter) what or where this is? I'm having the same issue where different elements/objects in the document are vertically printing in different positions from where they're supposed to be in the preview. I've tried different drivers and nowt I've tried is making a difference so far. It's doing my head in!

0
Avatar
Pete Thane
評論操作 永久連結

I dont think it is called that anymore as the original post was from 9 years ago.

It is one of two things either the default start of print position of the printer you need to adjust possibly just the Top Of From/Top Adjust setting as shown in the top image or, less frequently, the default start or print position (see bottom image) I maybe wrong but I seem to recall that the front panel settings of some of the older H and I class Datamax printers used to reference the Row and Column settings and these are now the same as the Horizontal/Vertical offsets in the driver. 

 

 

 

0
Avatar
James Mitchell
評論操作 永久連結

Was hoping it was a Bartender option! I've tried the Bartender drivers as well as the Zebra drivers and neither has fixed the issue sadly.

It's not offsetting the entirety of the label as one (that'd be an easy fix), it's just offsetting different elements on the template differently when printing. This happens with every .btw file I create on Bartender 2016. It's all shifted up on the vertical axis by a random amount - nothing moves horizontally out of place though.

I can try sending a couple of file sover to test if that helps? Appreciate the response to this 9 year old thread...!

0
Avatar
Pete Thane
評論操作 永久連結

One thing to look out for when using True Type fonts, is that the Substitute best matching printer font is NOT ticked for each of your text fields and when you receive the True Type warning you choose the option to continue printing True Types as with either of these options text items will look different on the screen to what is printed.

I assume you are using labels with a straight leading edge and not curved labels or ones with notches or gaps as that could cause an issue as the positioning of the label sensor can give sporadic results.

If normal square/rectangular labels then I would suggest to go back a few steps.

!. Power down the printer and then turn it back on. 

2. From the front panel of the printer return it to Factory Defaults. This will get rid of any settings that may have inadvertently been adjusted in the unit, although you may need to adjust the print method from direct to thermal if you are using a ribbon.

3. Once reset the printer should perform a calibration to pick up the label gap and after it has done this, feed a couple of labels to make sure if is picking up the gap correctly.

4. In BarTender create a brand new label, using the Seagull rather than ZDesigner driver but make sure you are using the correct DPI version of the printer. For the label size set the Width to include the backing material either side of the label whilst for the height just measure the height of the label itself and ignore the inter-label gap. Set the top and bottom margins to zero and adjust the left and right to allow for the backing paper showing to the size of each label.. 

5. From the File>Print Screen make sure the Document Properties > Stock tab is set to default values (image below) and the Page Setup > Advanced Options >Printing Position are both set to 0 too then close the Printer and Print dialogue screens

6. Add a "Sample Text" data field to the bottom edge and top edge of the label using the default Zebra font (Triumvirate normally), flipping one field by 180 degrees so you can tell the difference and then print a small batch of labels. 

7. If they print correctly trying adjusting the font to the one you want to use and retest it. 

If that again works I would suggest copy and pasting the fields from one of your existing labels onto this new template as that would eliminate any settings in your label. 

 

0
Avatar
James Mitchell
評論操作 永久連結

One thing to look out for when using True Type fonts, is that the Substitute best matching printer font is NOT ticked for each of your text fields and when you receive the True Type warning you choose the option to continue printing True Types as with either of these options text items will look different on the screen to what is printed.

You've done it mate! It was the fonts that was the issue. I changed it from the Zebra Swiss Unicode to Calibri for each text box and it printed in the exact location as in the template. Can't believe that was the issue, though I'm not surprised the fix was so simple!

Regarding the labels - I'm using curved labels for both the physical labels themselves and on the template, though as just mentioned it was the fonts as the issue and not the label type.

Time to fix up my templates! Cheers

0
Avatar
Pete Thane
評論操作 永久連結

Glad you are sorted. 

One issue to watch out for with curved labels is the position of the label sensor is not changed. If it is moved then this will change the start of print position as the sensor will "trigger" off a different part of the label and label will start printing from that point and not the correct leading edge location.

登入寫評論。