Duplicate Labels Printing Bartender/commander 追蹤

0
Avatar
Legacy Poster

Commander trigger folder only has 1 trigger file..

 

[attachment=1909:ScreenHunter_319 Nov. 11 09.10.jpg]

 

 

History Explorer Shows 2 Prints

 

[attachment=1911:ScreenHunter_317 Nov. 11 08.51.jpg]

 

 

 

There are 2 spooler services running.. Could this be causing the duplicates?

 

[attachment=1910:ScreenHunter_319 Nov. 11 08.55.jpg]

2 意見

0
Avatar
Ian Cummings
版主
評論操作 永久連結

Could it be that there are two print commands in the one Commander task??  Attaching the Commander task list would be helpful.

0
Avatar
Legacy Poster
評論操作 永久連結

We actually ran into a very similar (identical?) issue as this post.  Our setup is as follows:

  1. Create a new Commander task
    1. TCP/IP trigger
      1. Default port of 5170
      2. Trigger Event
        1. "Sequence of Characters Received"
        2. "End of Transmission" selected as the character
        3. All other settings as default
    2. Commands (3 types)
      1. ​BarTender
        1. All tabs are set to use the default values (including the "Print" checkbox)
      2. BTXML Script (unmodified from default)
      3. Send to TCP/IP Socket
        1. Select: "Via original inbound connection"
  2. Start the new task detecting
  3. Send a single print request ("Order 13") message to Commander (see below from the Commander log, anonymized and formatted for reading)
    1. "Order 13" prints as expected
  4. Send another single print request ("Order 14") message to Commander
    1. Previous label ("Order 13") UNEXPECTEDLY prints
    2. New label ("Order 14") prints as expected
  5. Send another single print request ("Order 15") message to Commander
    1. Previous label ("Order 14") now UNEXPECTEDLY prints
    2. New label ("Order 15") prints as expected

 

Notes:

  • This has proven easy to reproduce with a couple different .btw files
  • We are currently using the Enterprise Automation Edition, version 10.1 SR3 (Build 2954) on Windows Server 2012 R2 (64-bit)
  • This seems related to the Print checkbox in the Print tab on the BarTender Command Options dialog
    • If I uncheck that box, it removes the "/P" piece of the command parameters, and saving/restarting the task fixed this issue for us
    • If I then go to the General tab and manually add "/P" in the Additional Command Parameters box, it adds the appropriate text to the Command Parameters and the issue reappears

 

Workaround:

  1. Open the "BarTender Command Options" dialog from the task configuration
  2. On the "Print" tab, uncheck the Print option
  3. Restart the task

 

 


[Task Name] Label Interface
[Date/Time] 2/11/2016 1:00:00 PM
[BarTender Command] Command Handler: BarTender1 - C:\PROGRA~2\Seagull\BARTEN~1\BarTend.exe /P
[BTXML Script] Command Handler: BarTender1 - C:\PROGRA~2\Seagull\BARTEN~1\BarTend.exe /XMLScript=
<?xml version="1.0" encoding="UTF-8"?>
<XMLScript Version="2.0">
   <Command Name="Job1454962252746">
      <Print>
         <Format>C:\BT\LabelFormat.btw</Format>
         <PrintSetup>
            <Printer>LabelPrinter</Printer>
         </PrintSetup>
         <NamedSubString Name="Barcode">
            <Value>0000013-042-2016</Value>
         </NamedSubString>
         <NamedSubString Name="Text">
            <Value>Feb 11, 2016: Order 13</Value>
         </NamedSubString>
         <NamedSubString Name="Location">
            <Value />
         </NamedSubString>
         <NamedSubString Name="Size">
            <Value>150uL</Value>
         </NamedSubString>
         <NamedSubString Name="Type">
            <Value />
         </NamedSubString>
         <NamedSubString Name="OrderNumber">
            <Value>13</Value>
         </NamedSubString>
      </Print>
   </Command>
</XMLScript>

登入寫評論。