Trouble Printing From Commander As A Service 追蹤

0
Avatar
Legacy Poster

Hi All


We have a client who is running Commander (v10) on their Windows Server 2008 R2 (x64) machine. Version details: Application: Version=10.0 SR2; build=2863; Edition=Automation

 

We are automating Commander by dumping a text file into a folder. When we run Commander as an application, all works as expected. When we run Commander as a service, nothing prints.

 

Notes:
 

  • After the service starts up, the CmdrMsg.txt file contains a line "Started Commander service on computer TERMSERVER"
  • In the registry, under: HKLM\SOFTWARE\Wow6432Node\Seagul Scientific\Commander\Preferences, the "Config File" is set to the correct value of: C:\Navigator\NavigatorService.tl
  • The task list file contains details for several jobs - in each case, the file contains the trigger and passes a parameter to Bartender
  • In each task, detection mode is set to "Immediate" , with the detection response of "Delete File".
  • Symptom wise, the .dd file in our trigger folder is never deleted. The file can be deleted through Explorer - so it is not locked by any process.
  • The Commander service is running as the "Local Service" account. I have also tried running Commander under the same domain user I use when signing in to the machine.
  • When I run Commander from the Start Menu, the NavigatorService.tl file is loaded, but the "Start Detection" button is enabled. This says to me that while Commander *starts* as a service, the detection process does not start.
  • Under "General Options" /Startup, "detection" mode is set to "Start" and Task list is set to "Open Specified Task List", with the name being the correct file.
  • As far as permissions go, the task list file has "Everyone" granted "Full Control" (as well as the 'anonymous' user). The same goes for the .dd (trigger) file, the folder it resides in, and the folder the task list lives in.

Does anyone have any suggestions about how we can get better logging information out of Commander (or better yet, a working solution!)? We've spent a few days on this now and have had no luck!


Regards

Timothy Muir
RFBS

2 意見

0
Avatar
Ian Cummings
版主
評論操作 永久連結

To start with upgrade the BarTender Suite to the latest service release:

 

http://www.bartenderbarcodesoftware.com/label-software/fixes_100.aspx

 

1. The Commander service should be logged on under an account that has adequate permissions over the files and folders in use.

 

2. Does the trigger file contain data and/or commands?  If so then the task should rename the trigger file, not delete it.

 

3. I'm not clear on something; is the trigger file ever detected?  Is it detected but not renamed/deleted?  Is it detected, renamed/deleted, but then nothing prints?

 

4. Read through the Commander trouble shooter found at the below link:

 

http://seagullscientific.invisionzone.com/index.php?/topic/55-commander-troubleshooting/

0
Avatar
Legacy Poster
評論操作 永久連結

Thanks for the update - the issue was resolved by upgrading to Bartender 10 SR4.

登入寫評論。