Ignoring Unc Paths 追蹤

0
Avatar
Legacy Poster

Hi,

 

I have configured a task in Commander to detect *.csv files and print them.

 

If I pick the "Folder to Scan:" to be D:\IncomingData\ it works fine. But my live data folder is \\db2\labels (a linux box). As soon as I change my "Folder to Scan:" to this, Commander just ignores files landing here. I've tried restarting Commander, changing the detection method from immediate to polling, changing file encoding and the detection response from rename to delete. But none of these changes have any effect.

 

If I enable message logging to file, I can see messages for Commander restarting but nothing is logged when I drop my CSV files into \\db2\labels. It's as though BarTender Commander just doesn't like UNC paths and actively refuses to monitor them.

 

Please can someone offer some help or advice.

 

We're using the latest Automation Enterprise release by the way.

 

Thanks.

 

Elliot

4 意見

0
Avatar
Legacy Poster
評論操作 永久連結

I have also found that creating a desktop shortcut with the following command line options prints the document seemingly fine:

 

"C:\Program Files (x86)\Seagull\BarTender Suite\bartend.exe" /AF="C:\Users\ejohnson\Desktop\Seals v2 - Auto.btw" /PRN="LP-H002035" /P /D="\\db2\labels\label.csv" /Close

 

So it seems BarTender has no issue with UNC paths, but Commander does?

 

I don't believe this is a permissions issue, as I can manually add, rename and delete files at \\db2\labels\ from the BarTender server without issue.

 

Thanks

0
Avatar
Legacy Poster
評論操作 永久連結

I have now tried creating a network drive to \\db2\labels\. My new net drive 'S:\' is fine in Windows and I can browse it and use it, but Commander complains with the following error: 
 
"
[Task Name] Seals v2 Auto
[Error] Error 3 - Could not find or create the "S:\" folder - The system cannot find the path specified.
"
0
Avatar
Legacy Poster
評論操作 永久連結

Ok, I am getting somewhere.

 

I have changed my "Files to Scan for:" option from "*.csv" to "label.csv" and it works. So there is a problem with Commander using wildcards on linux/samba shares. Does anyone know of a solution or workaround? I really need this functionality.

 

Thanks.

 

Elliot

0
Avatar
Domingo Rodriguez
版主
評論操作 永久連結

Do you have this problem both when Commander is running as a service and when it runs as an application? You can switch between both via Commander's "Administer > Service Setup" dialog.

登入寫評論。