Commander Issues With Xml 追蹤

0
Avatar
Legacy Poster

Trying to setup a task that triggers when an XML file is created in the Scan folder.

The XML file is generated from our ERP system and not in BTXML format so i've transform it with an XSL-file.

See both attached (ERP.xml and TRANSFORM.xsl) [attachment=2045:ERP.txt][attachment=2046:TRANSFORM.txt]

 

See also the Commander settings

[attachment=2042:Task1.jpg]

[attachment=2041:Task2.jpg]

[attachment=2043:Transform.jpg]

 

But everytime the XML file is created I get an error.

[attachment=2044:Error.JPG]

 

Cant figure out what the error is? What am I doing wrong? :(

1 意見

0
Avatar
Ian Cummings
版主
評論操作 永久連結

I changed the header of the XSL to the below.  However, it should be noted that the result gave no actual record data in the CDATA section:

 

<?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="xml" version="1.0" indent="yes" cdata-section-elements="TextData"/>
<xsl:output omit-xml-declaration="no" encoding="UTF-8"/>
<xsl:strip-space elements="*"/>

To test your XSL more inteactively I recommend that you use this online tool:

 

http://xslt.online-toolz.com/tools/xslt-transformation.php

 

*Note that the site only supports XSL v1.0 so you'll need to modify that in the applicable xsl:stylesheet attribute.  You don't seem to be using an XSL v2.0 specific feature so that shouldn't be a problem.

 

The below site is also a good XSL reference resource:

 

http://www.zvon.org/comp/r/ref-XSLT_1.html#intro

登入寫評論。