Printer as shared resource works on designer but not in integration 追蹤

0
Avatar
Francisco Luis

Hi,
I am having problems with one printer.

Server with bartender 2019 suite.
Printer 1: Toshiba TEC B-SX4T  (Added manually by tcp/ip and selecting use disk for drivers)
Printer 2: Toshiba TEC B-EX4T1-GS12-QM-R   (Added as a shared resource navigating to \\printserver\\printerResource, and also tested with and without clicking use disk, tested all versions of B-EX4T1 drivers)

We can use both printers from bartender designer, but when we try to use  Printer 2 from an integration created with integration builder, it fails and generates 4 dump files.

The same integration works well with the other printer. Is there anyway I can analyze those dumps and see if I can find the issue?

I have another printer working perfectly in both Designer and Integrations.
The  Integration recieves a JSON with a printer variable containing the printer name (as shown on the server with bartender suite installed). 

I can provide the dump files if that helps tracing the issue. Any guesses of what could be the problem?
Thanks in advance.

4 意見

0
Avatar
Francisco Luis
評論操作 永久連結

The integration response contains the following error message:

La impresión del trabajo '8481_P.btw' no se ha completado debido al siguiente error: BarTender Image Dump: Saved dump file to 'C:\ProgramData\Seagull\BarTender\Dump\BarTend_004720_0007.dmp'

0
Avatar
Francisco Luis
評論操作 永久連結

Printserver 1: The server with bartender suite

Printserver 2: The server that shares all the other printers (except Printer1)

Printers names on printserver1 (and also received in json Printer variable):
Printer1:     TEC
Printer2:     XXX.YY.ZZZ

Maybe the driver fails when the printer name contains dots on it? Or when it translates into 
\\printserver2\\XXX.YY.ZZZ

When I add the printer to PrintServer1 by navigating to Printserver2 shared printers, it adds correctly, and I can print from the designer, but not from integrations. Adding the printer that way allows to print the test page and using printer2 from designer.

Thanks in advance.

Francisco.

0
Avatar
Peter Zalinski
評論操作 永久連結

Has this been resolved yet?  I have a custeiorm with a similar problem , and it's impeding our ability to roll out the integration.

 

0
Avatar
Ivaylo Arnaudov
評論操作 永久連結

We have the same issue.
When a printer is used as shared the printout is bad ( no barcode at least, other elements missing, template not falling into place ), same printer used as a TS/RDP redirected/easy print driver/ prints ok from Web Integration.

- Tried setting a local port and a UNC path : Not working
- Tried all sorts of driver settings : No success

Essentially the driver is the same version and bits on the remote server where the integration selects the printers from and on the local station from where it is shared. So should not be a driver difference issue.

That issue with using shared devices with Web Integration is existing and if someone have a workaround for printers that can not be converted to network devices ( LPT print servers are hard to find and usually do not work with thermals ), please, share.
Also any suggestions are welcome too, whatever you can think of, I'll try and post results at least to have a record of what have been tried, hopefully we'll find a workaround.

Thank you guys.

登入寫評論。