Bartender - Static data not printing 追蹤

0

Hello,

I have static objects on a template, followed by database information that is variable and is in a .csv file.

When printing using integration followed by / database information, it will print the first template correctly: all variable and all static information within it.

However, as it goes through 2nd, 3rd, 4th label, it will print only the database information and skip the static objects that were printed on the first label.

Example what is on the label Date: 10/10/2022 , where "Date:" is static and the "10/10/2022" is variable and using a database field.

It will print on the first label both of these values, and for the next labels it will not print "Date:" , only "10/10/2022" , which is the variable part.

This is happening to only one printer (sato) and from one computer and only when using Seagull driver.

Doing this on other printers and computers works just fine.

Tried the following:

Use Bartender 2019, 2022

Rasterize

Flush Printer cache.

No good.

Any suggestions ?

Thank you.

6 意見

0
Avatar
Pete Thane
評論操作 永久連結

It sounds like a possible printer issue to me.

To reduce the amount of data being sent BarTender will often send a command to cache the label on in the printers memory including the static data fields and then send commands to recall the label and print it with the variable strings. It maybe something is happening and this caching is failing and the fixed strings are not getting saved on the printer.

In your label format, open it in Designer and disable the Allow Static Objects from the Print>Performance tab and then resave the label and test it as that may help.

 

0
Avatar
Martin Flei
評論操作 永久連結

I tried it. It does not make any difference sadly.

I even tried to embedded a pdf as a background image, but it gets skipped on the 2nd label and only variable data is printed.

0
Avatar
Pete Thane
評論操作 永久連結

If you are using another Sato, can you create do a print run (for a few labels) to this but instead choose the Print to File option and create a PRN output.

 

To make sure this works for the existing printer, untick the print to file and then click Printer Properties > Tools > Actions and Send File to Printer. The printer should then print the label data in the file normal

 

Next send that file to the problematic printer and see what happens. 

 

0
Avatar
Martin Flei
評論操作 永久連結

The other printers are being used at other customer facilities that i do not have access now.

 

Is there anything else i can check within bartender ?

 

0
Avatar
Pete Thane
評論操作 永久連結

The problem looks to be one of two things, either a printer memory issue or file format issue. If you could do the testing above then that would help to eliminate one of those potentially.

Not sure what else to test unless you start a new test label with a a mix of static and variable fields and see how that performs. If the BTW format is corrupted in some way then that could possibly cause what you are seeing.

0
Avatar
Martin Flei
評論操作 永久連結

I've tried a new label from scratch, but it did not make a difference.

 

In case of a printer memory issue, what would the next steps be in troubleshooting ?

Same for file format issue , what next steps could i take to fix it ?

Thank you!

登入寫評論。